Motta en feil når du prøver å utføre legge migrasjon kommandoen i pakkebehandleren konsoll

stemmer
32

Jeg trenger et annet sett med øynene til å se på dette. Følgende kode blir kjørt i Visual Studio, og når det ikke er i bruk den grønne sidepanelet viser syntaksen er riktig.

Men når jeg kjører et tillegg migrasjon i manager-konsollen, den reagerer med følgende feil.

Ugyldig objektet gått i, ':' eller '}' forventet (817).

Det ser ut til å ta problemet med min avhengighet gjennomføringen, men jeg kan ikke finne noen forekomst av en manglende brakett eller komma.

Hvis du finner det vil jeg gjerne gi svaret med en opp stemme. Takk skal du ha!

{
  buildOptions: {
    emitEntryPoint: true,
    preserveCompilationContext: true
  },
  dependencies: {
    Microsoft.NETCore.App: {
      version: 1.0.1,
      type: platform
    },
    Microsoft.AspNetCore.Diagnostics: 1.0.0,
    Microsoft.Extensions.Configuration.FileExtensions: 1.0.0,
    Microsoft.AspNetCore.Server.IISIntegration: 1.0.0,
    Microsoft.AspNetCore.Server.Kestrel: 1.0.1,
    Microsoft.Extensions.Logging.Console: 1.0.0,
    Microsoft.Extensions.Configuration.Json: 1.0.0,
    Microsoft.AspNetCore.StaticFiles: 1.0.0,
    Microsoft.AspNetCore.Mvc: 1.0.0,
    Microsoft.EntityFrameworkCore.SqlServer: 1.1.0,
    Microsoft.EntityFrameworkCore.Tools: 1.1.0-preview4-final,
    Microsoft.AspNetCore.Identity: 1.0.0 //New package required for added functionality
  },
  frameworks: {
    netcoreapp1.0: {
      imports: [
        dotnet5.6,
        portable-net45+win8
      ]
    }
  },
  publishOptions: {
    include: [
      wwwroot,
      web.config
    ]
  },
  runtimeOptions: {
    configProperties: {
      System.GC.Server: true
    }
  },
  scripts: {
    postpublish: [ dotnet publish-iis --publish-folder %publish:OutputPath% --framework %publish:FullTargetFramework% ]
  },
  tools: {
    Microsoft.AspNetCore.Server.IISIntegration.Tools: 1.0.0-preview2-final,
    Microsoft.EntityFrameworkCore.Tools: 1.1.0-preview4-final
  }
}
Publisert på 22/11/2016 klokken 17:49
bruker
På andre språk...                            


1 svar

stemmer
6

Det eneste problemet jeg oppdager på json er kommentaren du har her

//New package required for added functionality

Kommentarer er ikke gyldig på en JSON struktur så sannsynligvis feilen er relatert til det.

Svarte 22/11/2016 kl. 17:54
kilden bruker

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more